SMITE/Rogue Company/Paladins/Realm Royale PlayStation Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This PlayStation login issue has been resolved.
Posted Jul 22, 2021 - 13:52 EDT
Monitoring
PlayStation logins have resumed at this time, and we are currently monitoring
Posted Jul 22, 2021 - 13:00 EDT
Update
We are currently investigating an issue with PlayStation logins for #SMITE, #RogueCompany, #Paladins, #RealmRoyale at this time.
Posted Jul 22, 2021 - 11:58 EDT
Investigating
We are currently investigating an issue with #Paladins logins for #PS4 players at this time.
Posted Jul 22, 2021 - 11:08 EDT
This incident affected: Realm Royale (Realm Royale PS4), SMITE (SMITE PS4), Rogue Company (Rogue Company PS4), and Paladins (Paladins PS4).