Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Paladins #PC has been resolved.
Posted Jun 27, 2017 - 17:05 EDT
Monitoring
We have implemented a fix for the issue in #Paladins #PC and are monitoring the results.
Posted Jun 27, 2017 - 16:52 EDT
Update
We are performing an emergency restart of #Paladins #PC. The game will be up shortly.
Posted Jun 27, 2017 - 16:43 EDT
Identified
We have identified an issue with #Paladins #PC and are actively working to resolve it.
Posted Jun 27, 2017 - 16:37 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Jun 27, 2017 - 16:30 EDT
This incident affected: Paladins (Paladins PC).