XBOX Live experiencing log-in problems
Incident Report for Hi-Rez Studios, Inc
Resolved
XBox appears to have recovered. All systems go. #SMITE Xbox is open for business.
Posted almost 2 years ago. Oct 01, 2015 - 20:03 EDT
Update
Xbox Live services appear to be returning to normal operation.
Posted almost 2 years ago. Oct 01, 2015 - 19:28 EDT
Identified
Xbox live is continuing to experience log in issues.
Posted almost 2 years ago. Oct 01, 2015 - 18:26 EDT
Investigating
Xbox live is currently having issues processing log in requests.
Posted almost 2 years ago. Oct 01, 2015 - 16:22 EDT