Currently experiencing network issues
Incident Report for Hi-Rez Studios, Inc
Resolved
All network connectivity issues impacting Hi-Rez products have been resolved #Paladins #Smite #Tribes
Posted 7 months ago. Oct 19, 2016 - 13:17 EDT
Investigating
We are Currently experiencing network issues that are affecting all games, we are investigating#smite #paladins # tribes
Posted 7 months ago. Oct 19, 2016 - 12:11 EDT