Smite Console Patch Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
The #Smite #PS4 and #Xbox 5.17 Upgrade has been completed.
Posted 28 days ago. Sep 19, 2018 - 09:33 EDT
Investigating
We are performing a patch maintenance for #Smite #PS4 #XBox tomorrow (09/19/2018) at 11:00 UTC. Limited logins will begin at 10:30 UTC.
Posted 28 days ago. Sep 19, 2018 - 06:40 EDT
This incident affected: Smite (Smite PS4, Smite Xbox).