Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Smite #PS4 has been resolved.
Posted 3 months ago. Jun 06, 2017 - 16:17 EDT
Monitoring
We have corrected an issue with #Smite #PS4 and are continuing to monitor.
Posted 3 months ago. Jun 06, 2017 - 16:12 EDT
Update
We are currently investigating this issue. #Smite #PS4
Posted 3 months ago. Jun 06, 2017 - 16:05 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 3 months ago. Jun 06, 2017 - 15:57 EDT
This incident affected: Smite PS4 - North America / Europe.