Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Intermittent data center connectivity issues. Has recovered.
Posted about 1 year ago. Feb 23, 2016 - 15:03 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Feb 23, 2016 - 14:48 EST