Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue detected for #Smite #Xbox has been resolved.
Posted 4 months ago. Jun 14, 2017 - 22:49 EDT
Update
We are performing another emergency restart for #Smite #Xbox. The game will return soon.
Posted 4 months ago. Jun 14, 2017 - 22:37 EDT
Update
We will be performing an emergency restart for #Smite #Xbox. The game will be up shortly.
Posted 4 months ago. Jun 14, 2017 - 22:17 EDT
Identified
We will be limiting logins on #Smite #Xbox briefly.
Posted 4 months ago. Jun 14, 2017 - 22:02 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 4 months ago. Jun 14, 2017 - 21:55 EDT
This incident affected: Smite Xbox - North America / Europe.