Realm Royale Pausing Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 08, 2018 - 16:12 EDT
Monitoring
Logins have resumed and we are continuing to monitor the situation.
Posted 2 months ago. Jun 08, 2018 - 15:50 EDT
Identified
We are temporarily pausing logins for Realm Royale
Posted 2 months ago. Jun 08, 2018 - 15:41 EDT
This incident affected: Realm Royale (Realm Royale PC).