Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 23 days ago. Nov 22, 2017 - 09:15 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 23 days ago. Nov 22, 2017 - 08:48 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 23 days ago. Nov 22, 2017 - 08:33 EST