Smite PC Limiting log ins
Incident Report for Hi-Rez Studios, Inc
Resolved
We have restored logins for smite pc#smite
Posted over 1 year ago. Aug 22, 2016 - 08:54 EDT
Investigating
We are limiting logins on smite pc for a few moments#smite
Posted over 1 year ago. Aug 22, 2016 - 08:34 EDT