Smite Xbox Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The login issue on #Smite #Xbox has been resolved and the game remains open to the general public.
Posted 2 months ago. Jun 13, 2018 - 01:54 EDT
Monitoring
We have implemented a fix for the #Smite #Xbox issue. The game is back up, and we are monitoring the results. We apologize for the inconvenience.
Posted 2 months ago. Jun 13, 2018 - 00:30 EDT
Identified
The cause of the #Smite #Xbox login issue has been identified, and we are working on a resolution. We will update accordingly.
Posted 2 months ago. Jun 12, 2018 - 23:31 EDT
Update
We are placing #Smite #Xbox under maintenance for further testing to properly identify the login issue.
Posted 2 months ago. Jun 12, 2018 - 20:44 EDT
Update
Logins have been temporarily limited for further investigation for #Smite #Xbox.
Posted 2 months ago. Jun 12, 2018 - 20:12 EDT
Update
The investigation for the root cause of the #Smite #Xbox login issue is still ongoing. We will continue to provide updates accordingly.
Posted 2 months ago. Jun 12, 2018 - 18:59 EDT
Investigating
We are investigating an issue with #Smite #Xbox logins. We will update accordingly.
Posted 2 months ago. Jun 12, 2018 - 17:24 EDT
This incident affected: Smite (Smite Xbox).