Xbox Live Services
Incident Report for Hi-Rez Studios, Inc
Resolved
XBox Live issues with respect to HiRez products seem to have subsided; XBox Live status page says certain minor issues are ongoing, but nothing that appears to be impacting HiRez products; Resolving Incident; For up to date Xbox Live service announcements, visit: http://support.xbox.com/en-US/xbox-live-status
Posted about 2 years ago. Aug 10, 2015 - 20:48 EDT
Identified
Some Xbox Live services are having an issue, which may affect the ability for some users to load SMITE, or to make SMITE purchases. For up to date Xbox Live service announcements, visit: http://support.xbox.com/en-US/xbox-live-status
Posted about 2 years ago. Aug 10, 2015 - 17:34 EDT