Paladins PC Incident
Incident Report for Hi-Rez Studios, Inc
Resolved
Game functionality has returned to normal.
Posted 20 days ago. Jun 03, 2018 - 17:50 EDT
Monitoring
Logins have resumed and we are continuing to monitor.
Posted 20 days ago. Jun 03, 2018 - 15:58 EDT
Update
We are continuing to work on a fix for this issue.
Posted 20 days ago. Jun 03, 2018 - 15:36 EDT
Identified
We've encountered an issue with #Paladins #PC and are limiting logins.
Posted 20 days ago. Jun 03, 2018 - 15:35 EDT
This incident affected: Paladins (Paladins PC).