Smite Connectivity Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Aug 17, 2016 - 19:17 EDT
Investigating
We are currently experiencing network connectivity issues to some of our EU servers.
Apologies for the Inconvenience.
#Smite
Posted almost 2 years ago. Aug 17, 2016 - 18:30 EDT