Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Sep 05, 2017 - 11:35 EDT
Monitoring
#Paladins PC restart has been completed.
Posted Sep 05, 2017 - 11:26 EDT
Identified
We will be performing an emergency restart of #Paladins PC in a moment
Posted Sep 05, 2017 - 11:14 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Sep 05, 2017 - 11:05 EDT