Smite PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The #Smite#PC emergency restart has been completed. We are monitoring the results.
Posted 4 months ago. Aug 04, 2018 - 19:38 EDT
Identified
There is currently an issue affecting some of the game services for Smite PC. We will be limiting player logins while we address the issue.
Posted 4 months ago. Aug 04, 2018 - 19:00 EDT
This incident affected: Smite (Smite PC).