Smite Xbox Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The restart for #Smite #Xbox has been completed.
Posted 16 days ago. Nov 01, 2018 - 12:49 EDT
Monitoring
The emergency restart for #Smite #Xbox has completed. The game is back up, and we are monitoring the results.
Posted 16 days ago. Nov 01, 2018 - 12:18 EDT
Identified
We are performing an emergency restart for #Smite #Xbox. We will update accordingly.
Posted 16 days ago. Nov 01, 2018 - 12:11 EDT
This incident affected: Smite (Smite Xbox).