Smite PC Temporarily Limiting Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have resumed for #Smite #PC.
Posted 8 months ago. Jan 10, 2019 - 07:23 EST
Identified
We are temporarily limiting logins for #Smite #PC to address an issue.
Posted 8 months ago. Jan 10, 2019 - 07:07 EST
This incident affected: Smite (Smite PC).