Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #SmitePC
Posted 5 months ago. May 12, 2017 - 15:13 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 5 months ago. May 12, 2017 - 15:03 EDT
This incident affected: Smite PC - North America / Europe.