Paladins XBox/Switch Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 13, 2018 - 16:46 EDT
Monitoring
Emergency restart has concluded, and logins have resumed. We will continue to monitor the issue.
Posted 5 months ago. Jul 13, 2018 - 15:41 EDT
Identified
We are performing an emergency restart for Paladins Xbox/Switch
Posted 5 months ago. Jul 13, 2018 - 15:25 EDT
Investigating
We are investigating the issues affecting logins for Paladins Xbox and Switch
Posted 5 months ago. Jul 13, 2018 - 15:16 EDT
This incident affected: Paladins (Paladins Xbox).