Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 01, 2017 - 22:22 EDT
Monitoring
We are continuing to monitor.
Posted about 2 months ago. Feb 01, 2017 - 20:00 EDT
Identified
We are currently working to restore connectivity to our game services.
We apologize for the inconvenience.
Posted about 2 months ago. Feb 01, 2017 - 19:23 EDT
Investigating
Automated services have detected a possible data center issue that may impact all games. We are investigating. #SMITE #Paladins #Tribes
Posted about 2 months ago. Feb 01, 2017 - 19:21 EDT
This incident affected: Smite PC - North America / Europe, Smite Xbox - North America / Europe, Smite PS4 - North America / Europe, Paladins PC, Paladins Xbox, Paladins PS4, Tribes Ascend, and Smite Tactics.