Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Hirez Games incident has been resolved.#Smite #tribes #paladins
Posted about 1 year ago. Apr 14, 2016 - 21:10 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted about 1 year ago. Apr 14, 2016 - 21:03 EDT