Launcher Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 30, 2018 - 10:17 EST
Investigating
We are investigating an issue players are having logging into our games via the launcher.
Posted 6 months ago. Jan 30, 2018 - 07:53 EST
This incident affected: Hand of the Gods (Hand of the Gods PC), Paladins (Paladins PC), and Smite (Smite PC).