Smite Xbox Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Smite #Xbox has been resolved.
Posted about 1 month ago. Oct 09, 2017 - 19:50 EDT
Monitoring
#Smite #Xbox emergency restart has been completed. We are monitoring the results.
Posted about 1 month ago. Oct 09, 2017 - 19:42 EDT
Investigating
We are performing an emergency restart for #Smite #Xbox. The game will be back shortly.
Posted about 1 month ago. Oct 09, 2017 - 19:26 EDT
This incident affected: Smite Xbox - North America / Europe.