Smite Xbox Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The restart incident with #Smite #Xbox has been resolved
Posted 9 days ago. Jul 13, 2018 - 10:45 EDT
Monitoring
The restart has been completed and players are able to get back in.
Posted 9 days ago. Jul 13, 2018 - 08:28 EDT
Investigating
We are performing an emergency restart on Smite Xbox.
Posted 9 days ago. Jul 13, 2018 - 08:08 EDT
This incident affected: Smite (Smite Xbox).