Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Smite #Xbox has been resolved.
Posted 5 months ago. Jul 04, 2017 - 03:12 EDT
Monitoring
We have corrected an issue with #Smite #Xbox and are continuing to monitor.
Posted 5 months ago. Jul 04, 2017 - 02:57 EDT
Identified
We have identified an issue with #Smite #Xbox and are actively working to resolve.
Posted 5 months ago. Jul 04, 2017 - 02:51 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 5 months ago. Jul 04, 2017 - 02:37 EDT
This incident affected: Smite Xbox - North America / Europe.