Paladins Logins Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved
Posted Oct 16, 2019 - 09:26 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 16, 2019 - 08:28 EDT
Investigating
We are currently investigating this issue.
Posted Oct 16, 2019 - 06:40 EDT
Monitoring
Game is back up and we are currently monitoring.
Posted Oct 16, 2019 - 06:16 EDT
Update
We are performing an Emergency Restart on #Paladins
Posted Oct 16, 2019 - 06:05 EDT
Investigating
We are currently experiencing login issues with #Paladins.
Posted Oct 16, 2019 - 05:58 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch).