Smite PC Potential Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #PC issue has been resolved.
Posted 11 days ago. Dec 03, 2018 - 12:40 EST
Investigating
We are temporarily limiting logins for #Smite #PC while we investigate an issue.
Posted 11 days ago. Dec 03, 2018 - 12:03 EST
This incident affected: Smite (Smite PC).