Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 11, 2018 - 16:47 EDT
Identified
We have identified the issue with Paladins PC and will be performing a restart of the environment momentarily
Posted 2 months ago. Apr 11, 2018 - 16:31 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 2 months ago. Apr 11, 2018 - 16:22 EDT