Paladins PC Emergency Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
The #Paladins #PC emergency server maintenance is complete.
Posted 8 days ago. Dec 06, 2018 - 15:39 EST
Monitoring
#Paladins #PC is back up, and we are monitoring the results.
Posted 8 days ago. Dec 06, 2018 - 14:55 EST
Identified
We have identified an issue with #Paladins #PC and are performing an emergency maintenance.
Posted 8 days ago. Dec 06, 2018 - 13:55 EST
This incident affected: Paladins (Paladins PC).