Limiting logins on Smite PC for a few minutes
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This smite pc incident has been resolved. #smitepc
Posted 5 months ago. Mar 17, 2017 - 19:24 EDT
Investigating
Limiting logins on Smite PC for a few minutes #SmitePC
Posted 5 months ago. Mar 17, 2017 - 19:03 EDT
This incident affected: Smite PC - North America / Europe.