Smite PC testing
Incident Report for Hi-Rez Studios, Inc
Resolved
The test is complete. Logins are available for PC #smite
Posted over 1 year ago. Aug 05, 2015 - 15:49 EDT
Investigating
New logins will be suspended for a few minutes for testing against an issue we are seeing in our live environment
Posted over 1 year ago. Aug 05, 2015 - 15:42 EDT