Smite Xbox Login Issues and Purchasing Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Feb 22, 2016 - 18:13 EST
Monitoring
XBL is having issues, Smite XBox players may have issues logging in or with purchases #smite
Posted over 1 year ago. Feb 22, 2016 - 15:50 EST