Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issue with #Smite #Xbox has been resolved.
Posted 24 days ago. Dec 31, 2017 - 01:51 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 24 days ago. Dec 31, 2017 - 01:18 EST
This incident affected: Smite Xbox - North America / Europe.