Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 months ago. Jan 04, 2017 - 00:12 EST
Identified
We are currently working to restore Match Making on #Paladins #PC.
Posted 10 months ago. Jan 04, 2017 - 00:03 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 10 months ago. Jan 03, 2017 - 23:58 EST
This incident affected: Paladins PC.