Smite Crossplay & PS4 Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #PC, #PS4, #Switch, & #Xbox issue has been resolved.
Posted 4 months ago. May 01, 2019 - 12:57 EDT
Investigating
We are currently investigating the login issues with #Smite #PC, #PS4, #Switch, & #Xbox.
Posted 4 months ago. May 01, 2019 - 12:15 EDT
This incident affected: Smite (Smite PC, Smite PS4, Smite Xbox, Smite Switch).