Smite, Realm Royale, and Paladins Login issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 29 days ago. Aug 24, 2019 - 00:22 EDT
Update
We are continuing to investigate this issue.
Posted 29 days ago. Aug 24, 2019 - 00:18 EDT
Update
Emergency restart is complete for Smite and Paladins. We will now be performing an emergency restart for Realm Roayle.
Posted 29 days ago. Aug 24, 2019 - 00:02 EDT
Update
We will be performing and emergency restart for Smite and Paladins.
Posted 29 days ago. Aug 23, 2019 - 23:28 EDT
Update
We are continuing to investigate this issue.
Posted 29 days ago. Aug 23, 2019 - 23:22 EDT
Investigating
We are investigating a login issue on Smite, Paladins, and Realm Royale.
Posted 29 days ago. Aug 23, 2019 - 23:12 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch), Smite (Smite PC, Smite PS4, Smite Xbox, Smite Switch), Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch), Hand of the Gods (Hand of the Gods PC, Hand of the Gods PS4, Hand of the Gods Xbox), and Tribes Ascend (Tribes Ascend PC).