Paladins PC Outage
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 14, 2018 - 12:51 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 9 months ago. Mar 14, 2018 - 12:37 EDT
Investigating
We are currently investigating this issue with Paladins PC.
Posted 9 months ago. Mar 14, 2018 - 12:34 EDT
This incident affected: Paladins (Paladins PC).