Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 months ago. Aug 02, 2016 - 09:26 EDT
Update
We are actively investigating the issues effecting queue times. Sorry for the inconvenience.
Posted 10 months ago. Aug 02, 2016 - 08:10 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 10 months ago. Aug 02, 2016 - 07:16 EDT