Unscheduled SMITE-PC Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite PC is now fully operational. #SMITE
Posted over 1 year ago. Sep 30, 2015 - 12:54 EDT
Investigating
We will be doing an unscheduled restart of SMITE-PC, servers will be going offline at 12:00PM EDT (6:00 PM CEST).

#SMITE
Posted over 1 year ago. Sep 30, 2015 - 11:34 EDT