TRIBES Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
#TRIBES is back on-line and taking players; apologies for the inconvenience...
Posted 11 months ago. Jun 24, 2016 - 16:32 EDT
Identified
We need to perform an emergency restart of #Tribes; the game will be back on-line shortly.
Posted 11 months ago. Jun 24, 2016 - 16:04 EDT