Network problems
Incident Report for Hi-Rez Studios, Inc
Resolved
Both environments are operating normally. We will continue to monitor
Posted over 1 year ago. Oct 18, 2015 - 14:53 EDT
Monitoring
XBox appears to be back to normal, PC is recovering also
Posted over 1 year ago. Oct 18, 2015 - 14:46 EDT
Investigating
We are having network problems causing people to re-login both PC and XBOX Smite
Posted over 1 year ago. Oct 18, 2015 - 14:35 EDT