Queue Reset for Smite PC
Incident Report for Hi-Rez Studios, Inc
Resolved
Maintenance Complete #Smite #PC
Posted 11 months ago. Aug 17, 2016 - 08:25 EDT
Identified
We will be resetting queues for the next few minutes on #SMITE PC. Logins will be suspended
Posted 11 months ago. Aug 17, 2016 - 08:04 EDT