Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We will be performing an emergency restart of #Paladins #Pc
Posted 2 months ago. Jun 16, 2017 - 11:57 EDT
Update
We are investigating an issue with #Paladins #PC
Posted 2 months ago. Jun 16, 2017 - 11:53 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 2 months ago. Jun 16, 2017 - 11:40 EDT