Realm Royal Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 09, 2018 - 14:10 EDT
Monitoring
Logins have resumed and we are continuing to monitor the situation.
Posted 6 months ago. Jun 09, 2018 - 13:48 EDT
Investigating
We are investigating the issue with logging into Realm Royale.
Posted 6 months ago. Jun 09, 2018 - 13:04 EDT
This incident affected: Realm Royale (Realm Royale PC).