Paladins PC, Xbox, Switch, and PS4 Login issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 05, 2019 - 17:47 EDT
Monitoring
Logins have resumed. We are continuing to monitor.
Posted 3 months ago. Apr 05, 2019 - 14:56 EDT
Investigating
We are investigating login issues for Paladins.
Posted 3 months ago. Apr 05, 2019 - 14:45 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch).