Paladins PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart has been completed
Posted 9 months ago. Jan 10, 2018 - 03:46 EST
Identified
We will be restarting Paladins PS4 momentarily
Posted 9 months ago. Jan 10, 2018 - 03:32 EST
Investigating
Automated services have detected a possible problem with #Paladins PS4. We are investigating.
Posted 9 months ago. Jan 10, 2018 - 03:24 EST
This incident affected: Paladins (Paladins PS4).