Paladins Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The #Paladins #PC, #Switch, & #Xbox emergency restart has been completed.
Posted 16 days ago. Jun 03, 2019 - 12:57 EDT
Identified
We are performing an emergency restart for Paladins #PC, #Switch, & #Xbox. Game will be back up soon.
Posted 16 days ago. Jun 03, 2019 - 12:19 EDT
This incident affected: Paladins (Paladins PC, Paladins Xbox, Paladins Switch).