Paladins PC Server Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 06, 2018 - 15:18 EDT
Investigating
We are currently investigating this issue.
Posted 4 months ago. Aug 06, 2018 - 14:50 EDT
This incident affected: Paladins (Paladins PC).